2024-05-08 13:06:44 +02:00

26 lines
432 B
Nix

{
description = "Ansible";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
};
outputs = { self, nixpkgs, ... }:
let
system = "x86_64-linux";
pkgs = nixpkgs.legacyPackages.${system};
in {
devShells.${system}.default = pkgs.mkShell {
buildInputs = with pkgs; [
openssh
sshpass
ansible
ansible-lint
];
};
};
}