29 lines
451 B
Nix
29 lines
451 B
Nix
{
|
|
description = "Rust setup";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, ... }:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in {
|
|
devShells.${system}.default = pkgs.mkShell {
|
|
|
|
buildInputs = with pkgs; [
|
|
openssl
|
|
|
|
clippy
|
|
rustfmt
|
|
|
|
cargo
|
|
cargo-watch
|
|
];
|
|
|
|
};
|
|
};
|
|
}
|
|
|